Developers' Forum

jobe not compatible with php 7.2?

 
Picture of Richard Lobb
Re: jobe not compatible with php 7.2?
by Richard Lobb - Sunday, 20 May 2018, 10:29 PM
 

Hi Martin

I just fired up Jobe on an Ubuntu 18.04 system. The only change I needed to make to the install instructions was to drop php-mcrypt from the dependency list, as you said. I also updated the version of Java that I installed, but I don't think that was necessary. I didn't need to make any of the other changes, so perhaps your Ubuntu 18.04 system was different from mine? I used a Digital Ocean Ubuntu 18.04 out-of-the-box server as a starting point.

I think the mycrpt library is needed for API-key authentication so that functionality currently doesn't work on Ubuntu 18.04.

testsubmit.py needed to be updated to handle the most recent version of pylint3, which insists on announcing what config file is using.

I've documented all this, and updated testsubmit.py, in the development branch of Jobe. I'll merge it back into master when I've done a bit more testing.

Thanks for providing the motivation.

Richard