Developers' Forum

PRECHECK not working?

 
Picture of Richard Lobb
Re: PRECHECK not working?
by Richard Lobb - Thursday, 13 September 2018, 9:52 AM
 

The usual reason for a missing result table is that the question is not being run in Adaptive Mode and/or that the Review options have not been set to show feedback during the attempt.

If that's not the problem in this case, please provide further information, such as what the actual output is, whether it's only Precheck that fails (i.e., does Check work?) and what language/question type you're using. A screen dump of the result would help, too.

I am in the process of changing the server that jobe2.cosc.canterbury.ac.nz maps to, so it's possible there's a problem there. You could try using 206.189.217.31 instead of jobe2.cosc.canterbury.ac.nz. Note, though, that I'll be decommissioning that server in a couple of days.

Richard

Picture of eduardo furtado
Re: PRECHECK not working?
by eduardo furtado - Thursday, 20 September 2018, 3:40 AM
 

Sorry for taking so long to reply, I was traveling.


I tried using 206.189.217.31 but that didn't work.

After that I tried what you mentioned at first, and indeed the questions was not being run in Adaptive Mode and/or that the Review options have not been set to show feedback during the attempt.


Now it's working, but the drawback is that I didn't want to enable people to check their answer for the other questions.


In the future everyone should be running their own jobe servers?

Picture of Richard Lobb
Re: PRECHECK not working?
by Richard Lobb - Thursday, 20 September 2018, 10:08 AM
 

Quizzes with a mixture of CodeRunner and non-CodeRunner questions are a bit tricky. For formative feedback I stick with showing  feedback immediately - students are much more motivated, and learn more, if they get instant feedback on their answers. For summative assessment (tests, exams) you need to compromise a bit. You can run the quiz in, say, Deferred Feedback mode but set the Review Options for "During the Attempt" to show feedback but hide correct answer, whether correct and mark. CodeRunner questions always display the Check and Precheck buttons (if enabled) regardless of mode. You need to experiment to find the best mix for your needs. Be warned that some question types (e.g. Cloze) leak information if you navigate away and back again.

Yes, everyone should run their own Jobe servers. I can't provide a compute service for the entire planet :)

Setting up a Jobe server in the cloud, such as on DigitalOcean, takes about 20 minutes and costs as low as $5 per month. See this video. Or if Docker is installed (which even works on Windows) you can run Jobe in a Docker container with just a single command. You can even do that on your Moodle server, though I don't recommend that, for both security and load reasons.

Richard