Developers' Forum

Problem with Jobe Server

 
Picture of Richard Lobb
Re: Problem with Jobe Server
by Richard Lobb - Wednesday, 26 September 2018, 8:51 AM
 

numpy is rather resource hungry. You will need to raise the memory limit in the runguard sandbox on Jobe. If you're going to be using numpy a lot you'll probably want to create a new python3 prototype (editing the existing one isn't recommended) with increased limits, but for now I suggest you experiment by editing just that particular question. In the author edit form, click the Customise checkbox, then open the Advanced Customisation panel. Increase the memory limit to 500 MB as shown in the image below. The image also shows an increased setting for the process limit (numprocs) but that shouldn't be necessary unless you have a huge number of cores on your Jobe server.

Advanced customisation for numpy

Richard