Developers' Forum

Help with CodeRunner

Help with CodeRunner

de Levi Osborne -
Número de respuestas: 1

I'm pretty sure this isn't the correct place, but I'm not quite sure where else to go for help.

I am running Moodle 3.9 on an AWS server to teach coding in python. I am running the Coderunner plugin 4.0.2 with a DigitalOcean droplet as my Jobe Server. I haven't had a single issue with it since install in the fall of 2018. 

However, it has suddenly stopped working. When running code I get the following errors "An unexpected error occurred. The sandbox may be down. Try again shortly." and "

Failed to run tests

Unexpected error while executing your code. The sandbox server may be down or overloaded. Perhaps try again shortly?"

I have no idea why. I checked settings in the coderunner plugin to make sure the ip didn't get deleted, but everything looks normal. I checked the droplet and I don't see anything wrong there either. I am definitely not a wiz at the server side of things and am all self-taught (bad news, I know) but following the tutorials you've posted around the internet has served me fantastically. What should my next steps be to solve this issue? Students start actually using coderunner next week, so I'd love to have it solved by then if possible.

En respuesta a Levi Osborne

Re: Help with CodeRunner

de Richard Lobb -

That message usually means that the Moodle server can't communicate with the Jobe (sandbox) server. If it was working before then I'd guess either the Jobe sandbox server or droplet stopped working or the networking/firewalling has changed and is now preventing the connection.

Some things to try:

  1. In the CodeRunner admin settings page, set the Jobe sandbox URL and API_Key back to their default values. Can you run questions now?
  2. From a command line try the following two bash commands:

    wget --header="X-API-Key: 2AAA7A5415B4A9B394B54BF1D2E9D" jobe2.cosc.canterbury.ac.nz/jobe/index.php/restapi/languages
    wget [yourjobeinaboxserverandport]/jobe/index.php/restapi/languages
    Both should work. If neither work you have a networking problem. If the first works and the second doesn't, your jobe server is down.
Let us know what happens.

Richard