jobe not compatible with php 7.2?

jobe not compatible with php 7.2?

by Martin Zwerschke -
Number of replies: 3

Hi Richard,

i tried to install jobe on a test server with latest ubuntu 18.04.

This one now uses "PHP 7.2" instead of 7.1 and "openjdk-11".

Installation of the jobe prerequisites fails even when i replace openjdk-9 with 11 in the apt install because php-module "php-mcrypt"

is depraciated and not longer supported in PHP7.2.

Afterwards jobe install script runs and everything seems OK. But returns only 404 errors:

 Response: 404 Not Found <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<title>404 Not Found</title>
<h1>Not Found</h1>
<p>The requested URL /jobe/index.php/restapi/runs/ was not found on this server.</p>
<address>Apache/2.4.29 (Ubuntu) Server at localhost Port 80</address>

Perhaps these are separate matters. But at least jobe should not longer rely on "php-mcrypt".

As i mentioned, this was not on a production server, but just an experiment. So there is no hurry on fixing this.

Just wanted to let you know.

In reply to Martin Zwerschke

Re: jobe not compatible with php 7.2?

by Martin Zwerschke -


The matter with 404 errors was caused by php-scripts were not executed at all.

I got rid of 404 errors by:

a2dismod mpm_event

a2enmod mpm_prefork

a2enmod php7.2

Now  can be executed again.

I can not see problems resulting from the not installable php-mcrypt, but at least for

php7.2 / Ubuntu 18.04 it should not be listed in the prerequisites any more.

In reply to Martin Zwerschke

Re: jobe not compatible with php 7.2?

by Richard Lobb -

Thanks for the heads up on this Martin, and the workarounds.

I haven't had time to look into it yet. I did quickly try building JobeInABox on Ubuntu-18 but had other issues. 

I'm not sure exactly what php-mcrypt is doing there, but I suspect it was required by the API-KEY functionality in the Code Igniter framework I use for Jobe. Have you tried your new server with API keys?

I'll look into all this when I next have some free time,  hopefully at the end of our current term (4 weeks away).

Thanks again


In reply to Richard Lobb

Re: jobe not compatible with php 7.2?

by Richard Lobb -

Hi Martin

I just fired up Jobe on an Ubuntu 18.04 system. The only change I needed to make to the install instructions was to drop php-mcrypt from the dependency list, as you said. I also updated the version of Java that I installed, but I don't think that was necessary. I didn't need to make any of the other changes, so perhaps your Ubuntu 18.04 system was different from mine? I used a Digital Ocean Ubuntu 18.04 out-of-the-box server as a starting point.

I think the mycrpt library is needed for API-key authentication so that functionality currently doesn't work on Ubuntu 18.04. needed to be updated to handle the most recent version of pylint3, which insists on announcing what config file is using.

I've documented all this, and updated, in the development branch of Jobe. I'll merge it back into master when I've done a bit more testing.

Thanks for providing the motivation.