Developers' Forum

Jobe server execution error

Jobe server execution error

by Vardhan W -
Number of replies: 2

Hi,

I installed local jobe server (as root) to test the CodeRunner plugin (the default server seems to have an issues connecting, and I anyway need a local server).

It is running on Ubuntu 16.04. I installed the necessary dependencies as per the documentation here https://github.com/trampgeek/jobe. Install was successful.

When I run the simpletest.py, it throws the error while executing any commands e.g: "Running python...
Compile error
Compiler output:
sudo: sorry, you must have a tty to run sudo"

Googling, I found that this needs the "Defaults requiretty" to be removed from the /etc/sudoers file. If I do that, I get the next level of error instead of the above: "sudo: no tty present and no askpass program specified"

This needs an update in the /etc/sudoers file to allow execution without password for the user and the commands. I see that there is a /etc/sudoers.d/jobe-sudoers file created with commands for www-data user (apache user) for a list of commands (including runguard - which was built successfully, but no compiler commands - is this expected?). I don't know/think that I should manually do anything (e.g. add commands to /etc/sudoers), as the install script should have worked and done the necessary updates (it did not throw any error/warnings).

Pls help on how to proceed with this issue.

thanks,

regards,

-Vardhan


In reply to Vardhan W

Re: Jobe server execution error

by Vardhan W -

Update: Checking this further I found that my /etc/sudoers file did not have the #includedir /etc/sudoers.d command at the end - as it should be. I had done a server upgrade from 14.04 to 16.04, maybe it did not update the /etc/sudoers file then(?). I manually added the #includedir directive (with 'sudo visudo') and also kept the Defaults requiretty commented.

With this the test seems to work Ok.

In reply to Vardhan W

Re: Jobe server execution error

by Richard Lobb -

Hi Vardhan

Good to know you seem to have solved the problem yourself. 

Thanks for the heads up on the issue with jobe2. I wasn't aware it wasn't working well. I just looked at it, and it seems some sites have been abusing the service. Also it hadn't been rebooted for over a year. So I've rebooted it and put in a firewall block on three IPs that were flooding it. It seems to be going ok again.

By the way, if you have any further issues with your local jobe server, you might want to consider jobeinabox. Once you've installed docker, you can run up a jobe server in one command. 

Richard