Developers' Forum

Need Help/Advice

Need Help/Advice

by Maryam Mehdigholi -
Number of replies: 10

Hi all,

Can anyone help me with the following error: 

An error occurred while processing your responses (qtype_coderunner/Language python3 is not available on this system). 

I am at the very new to this. I have installed the two plugins for CodeRunner. I tried a question in java and one in Python and both come up with this error (or in case of java: qtype_coderunner/Language Java) when checking an answer for the question created.

Any suggestions to fix this issue will be greatly appreciated.


In reply to Maryam Mehdigholi

Re: Need Help/Advice

by Richard Lobb -

The set of available languages is defined by whatever sandbox(es) is enabled. It sounds like there aren't any!

Log in to Moodle as an administrator and check in the CodeRunner admin panel (Site Administrations > Plugins > CodeRunner) that "Enable jobesandbox" is checked (enabled). Also, while testing I recommend you use the University of Canterbury outward-facing Jobe server,  jobe2.cosc.canterbury.ac.nz with the default API key.

When that's all working you should look into setting up your own Jobe server, but let's get this configuration working first.

Richard

In reply to Richard Lobb

Re: Need Help/Advice

by Maryam Mehdigholi -

Hi Richard,

Thank you so much. You solved the issue.

I might need help with setting up my own Jobe server. Any advise will be appreciated.

Rigards,

Maryam

In reply to Maryam Mehdigholi

Re: Need Help/Advice

by Richard Lobb -

Good to know the problem is solved.

There are fairly full Jobe install instructions at the Jobe repository (https://github.com/trampgeek/jobe) but if something goes wrong, feel free to ask for help.

Richard

In reply to Richard Lobb

Re: Need Help/Advice

by serap akgoz -

hi,

I couldnt see coderunner in plugins, i just see below, but i can not do anything. help pls



ss

ss


In reply to serap akgoz

Re: Need Help/Advice

by Maryam Mehdigholi -

Hi serap akgoz,

You are going down the wrong path.. Go Site Administrator > Advance Features > Plugins > Plugins overview > then on the right hand side (I have to scroll down to the middle) you will see CodeRunner and the settings in front of it.

I hope this helps.

Maryam 

In reply to Maryam Mehdigholi

Re: Need Help/Advice

by serap akgoz -

actually i saw what you say but i can not do anything. It looks disabled and can not see setting page.

s

In reply to serap akgoz

Re: Need Help/Advice

by Richard Lobb -

Do you have the latest version of the qbehaviour_adaptive_adapted_for_coderunner behaviour installed? It's available from here in the Moodle plugins repository or here on GitHut. CodeRunner will be disabled if the dependency isn't satisfied.

Richard

In reply to Richard Lobb

Re: Need Help/Advice

by serap akgoz -

oooh yes i have, have to uninstall?s

In reply to serap akgoz

Re: Need Help/Advice

by Richard Lobb -

I don't really know what has happened here. I see that it's not the latest version of the behaviour but I don't know why it's disabled. You could try upgrading it to the latest version but I suspect that won't help. Does the Moodle notifications page suggest anything?

Has this problem occurred with a fresh install of CodeRunner or did you used to have a working version which has now stopped working? If it used to work, what happened just before it stopped working?

If no-one here has any suggestions you might have to try a more general Moodle forum. This doesn't look like it's CodeRunner specific.

Richard