Running dotnet cli on jobe

Re: Running dotnet cli on jobe

by Dominique YOLIN -
Number of replies: 0
Hello Richard,

thank you so much for your quick response I really appreciate it.
I saw earlier post about mono, but since dotnet was release afterward, I did not even think about trying to install and use it, I was under the wrong assumption it was deprecated.

I installed it and run the test with a single file and it worked well

Then I tried to build a csproj since I want to be able to build a program with several source file, but I did not find a way to do it with mono (it seem msbuild and xbuild are both deprecated and mcs does not handle .csproj). But when I give all the cs file to the command line everything work fine and I'm able to create a test with multiple file for a single program

I just changed the cmd to
command_files = [ "mcs", "-out:tester.exe"]
for root, dirs, files in os.walk(os.getcwd()):
for file in files:
if file.endswith(".cs"):
command_files.append(os.path.join(root, file))

completedProc =,env=cs_env )

Thank you again for your help and great work on code runner :)