Table: cells do not lock anymore

Table: cells do not lock anymore

by Thomas Goerttler -
Number of replies: 1


I tried creating a new exercise with a table and realized that "locked_cells" no longer works.
I also tried to use "table_locked_cells" since I found it online, but that seems to be the old key.
I looked back to several questions I had created before and realized that the questions there also do not have any locked cells anymore.
This is dangerous in some exercises since the full result is analyzed (so students can simply answer their questions by themselves).

Is this issue related to the Moodle 4 update?
I have testet it on two differnt moodles.


In reply to Thomas Goerttler

Re: Table: cells do not lock anymore

by Richard Lobb -
Thanks for reporting Thomas. This looks to be a regression introduced when the table functionality was changed to use input elements rather than text areas when there's only one line per cell - around August this year.

It's fixed in the development branch on github - you can pull just the files amd/src/ui_table.js, amd/build/ui_table* and purge all caches if you're desperate for a fix. Otherwise I hope to push all recent updates to master and to the Moodle repo by Christmas.